1
I Use This!
Very High Activity

Commits : Listings

Analyzed about 11 hours ago. based on code collected 1 day ago.
Nov 07, 2025 — Nov 07, 2026
Commit Message Contributor Files Modified Lines Added Lines Removed Code Location Date
New utils class for the extensions defined in RFC 3546 More... over 13 years ago
Fix comment More... over 13 years ago
OCSPStatusRequest struct for use with "Certificate Status Request" extension from RFC 3546 More... over 13 years ago
New handshake message types from RFC 3546 More... over 13 years ago
New enum type from RFC 3546 More... over 13 years ago
Javadoc More... over 13 years ago
added KeyUsage validator. added check for unhandled critical extensions. More... over 13 years ago
more tweaking More... over 13 years ago
some more "bright ideas" More... over 13 years ago
initial cut of general CertPath package More... over 13 years ago
added JavaDoc link More... over 13 years ago
Merge remote-tracking branch 'origin/master' More... over 13 years ago
update More... over 13 years ago
Fixed wrappers to properly recognise parameter objects when made available. Moved provider to beta More... over 13 years ago
Move cast after instanceof check More... over 13 years ago
Implementation of RFC 6655, "AES-CCM Cipher Suites for Transport Layer Security (TLS)". More... over 13 years ago
Very basic support for key re-use in CCM mode, and enable test case. More... over 13 years ago
Formatting More... over 13 years ago
Include the whole cipher operation under the try-block More... over 13 years ago
Merge branch 'master' of git.bouncycastle.org:bc-java More... over 13 years ago
Implementation of RFC 5487, "Pre-Shared Key Cipher Suites for TLS with SHA-256/384 and AES Galois Counter Mode". More... over 13 years ago
Merge remote-tracking branch 'origin/master' More... over 13 years ago
update More... over 13 years ago
Remove unused import More... over 13 years ago
refactoring of OAEP More... over 13 years ago
Merge branch 'master' of git.bouncycastle.org:bc-java More... over 13 years ago
Update OCB mode and tests for changes in new draft "draft-irtf-cfrg-ocb-03" More... over 13 years ago
added deprecation More... over 13 years ago
minor cleanups More... over 13 years ago
added support for generation of OAEP encrypted enveloped data. minor cleanups More... over 13 years ago