1
I Use This!
Very High Activity
Analyzed 1 day ago. based on code collected 2 days ago.

This project has been reported as a duplicate of Bouncy Castle. This project will be deleted upon review by an Open Hub administrator.

 

Project Summary

The Bouncy Castle APIs currently consist of the following:

A lightweight cryptography API for Java and C#.

A provider for the Java Cryptography Extension and the Java Cryptography Architecture.

A clean room implementation of the JCE 1.2.1.

A library for reading and writing encoded ASN.1 objects.

Lightweight APIs for TLS (RFC 2246, RFC 4346) and DTLS (RFC 4347).

Generators for Version 1 and Version 3 X.509 certificates, Version 2 CRLs, and PKCS12 files.

Generators for Version 2 X.509 attribute certificates.

Tags

No tags have been added

In a Nutshell, bouncy Castle Java...

Project Security

Vulnerabilities per Version ( last 10 releases )

Project Vulnerability Report

Security Confidence Index

Poor security track-record
Favorable security track-record

Vulnerability Exposure Index

Many reported vulnerabilities
Few reported vulnerabilities

Did You Know...

  • ...
    55% of companies leverage OSS for production infrastructure
  • ...
    you can subscribe to e-mail newsletters to receive update from the Open Hub blog
  • ...
    use of OSS increased in 65% of companies in 2016
  • ...
    by exploring contributors within projects, you can view details on every commit they have made to that project
About Project Security

Languages

Java
99%
5 Other
1%

30 Day Summary

Oct 8 2026 — Nov 7 2026

12 Month Summary

Nov 7 2025 — Nov 7 2026
  • 4103 Commits
    Up + 1771 (75%) from previous 12 months
  • 28 Contributors
    Up + 7 (33%) from previous 12 months

Ratings

Be the first to rate this project
Click to add your rating
  
Review this Project!