1
I Use This!
Very High Activity

Commits : Listings

Analyzed about 7 hours ago. based on code collected about 9 hours ago.
Oct 30, 2025 — Oct 30, 2026
Commit Message Contributor Files Modified Lines Added Lines Removed Code Location Date
Call TlsServer.getCertificateStatus, if applicable, and send certificate_status handshake message accordingly More... over 13 years ago
Add new method TlsServer.getCertificateStatus (RFC 3546) More... over 13 years ago
Formatting More... over 13 years ago
first cut of RFC 6637 key handling More... over 13 years ago
fixed byte handling in getInstance() More... over 13 years ago
Javadoc spelling More... over 13 years ago
Track whether or not a certificate_status message is allowed More... over 13 years ago
New struct CertificateStatus for use with certificate_status handshake message More... over 13 years ago
Code cleanup More... over 13 years ago
TlsUtils.readASN1Object must always read exactly one object More... over 13 years ago
Basic protocol outline for certificate_status handshake messages More... over 13 years ago
Add new struct from RFC 3546, and change TlsExtensionsUtils to use it More... over 13 years ago
Use utility method More... over 13 years ago
New utils class for the extensions defined in RFC 3546 More... over 13 years ago
Fix comment More... over 13 years ago
OCSPStatusRequest struct for use with "Certificate Status Request" extension from RFC 3546 More... over 13 years ago
New handshake message types from RFC 3546 More... over 13 years ago
New enum type from RFC 3546 More... over 13 years ago
Javadoc More... over 13 years ago
added KeyUsage validator. added check for unhandled critical extensions. More... over 13 years ago
more tweaking More... over 13 years ago
some more "bright ideas" More... over 13 years ago
initial cut of general CertPath package More... over 13 years ago
added JavaDoc link More... over 13 years ago
Merge remote-tracking branch 'origin/master' More... over 13 years ago
update More... over 13 years ago
Fixed wrappers to properly recognise parameter objects when made available. Moved provider to beta More... over 13 years ago
Move cast after instanceof check More... over 13 years ago
Implementation of RFC 6655, "AES-CCM Cipher Suites for Transport Layer Security (TLS)". More... over 13 years ago
Very basic support for key re-use in CCM mode, and enable test case. More... over 13 years ago