41
I Use This!
Activity Not Available

News

Analyzed over 2 years ago. based on code collected almost 3 years ago.
Posted over 9 years ago by wen...@gmail.com (Weng Xuetian)
Only notice: This need to be used with libpinyin at least 0.9.91. Not hardly tested, need to be use with caution.
Posted over 9 years ago by wen...@gmail.com (Weng Xuetian)
fcitx-mozc-1.6.1187.102.4 and fcitx-mozc-1.10.1390.102.2 now available for downloads. It now implements "reconvert" and it will use vertical candidate list by default and also includes some other bug fix. For packager, it requires at least fcitx 4.2.7 since it's using fcitx- clipboard introduced in 4.2.7.
Posted over 9 years ago by wen...@gmail.com (Weng Xuetian)
OK.. a hot fix, for shuangpin might cause crash when using cloudpinyin. Sorry for that. In foreseeable future, there might be at least 0.2.92 to complete dictonary management and final 0.3.0. But if any packager already pick 0.2.90 up, please update to 0.2.91.
Posted over 9 years ago by wen...@gmail.com (Weng Xuetian)
Ok ok... we finally work with libpinyin upstream and fix all compatible problem. Usually, fcitx don't use x.y.90 for RC, but to avoid more libpinyin "random" upstream api change in 0.8.93 -> 0.9.0, 0.2.90 is introduced. And even if there is no necessary changes to be done for libpinyin 0.9.0,
Posted over 9 years ago by wen...@gmail.com (Weng Xuetian)
One important note, this version actually now can only compile with cmake 2.8. We commit a patch for compatible with cmake lower than 2.8.3 in git, but you still need to use cmake 2.8.x. CentOS6 can use EPEL[1] to install cmake 2.8 [1] [link]
Posted over 9 years ago by wen...@gmail.com (Weng Xuetian)
All components in this release will depend on fcitx 4.2.7 due to they are using the new build macro. Now we have a new template repo for whom want to develop new addon for fcitx: [link] And for kdevelop user: Create a new tar.bz2 with this branch, and now you can create fcitx project
Posted over 9 years ago by wen...@gmail.com (Weng Xuetian)
bug fix release, recommends everyone to upgrade. 1. Fix a typo in default m17n list 2. Fix latn-post u + : and some similar composition
Posted over 9 years ago by wen...@gmail.com (Weng Xuetian)
bugfix release, fix some possible crash.
Posted over 9 years ago by wen...@gmail.com (Weng Xuetian)
since qt5 is released, let's release this initial support for qt5 application first. It might have packaging problem, please report bug if it cannot install to right place.
Posted over 9 years ago by wen...@gmail.com (Weng Xuetian)
Hi, fcitx-hangul 0.2.0 is released. Recommend to upgrade to this version. Including fix of many incorrect behavior. Regards