20
I Use This!
Moderate Activity

Commits : Listings

Analyzed about 17 hours ago. based on code collected 1 day ago.
Apr 29, 2023 — Apr 29, 2024
Commit Message Contributor Files Modified Lines Added Lines Removed Code Location Date
fix refactoro
tg
More... about 2 years ago
whitespace and minor nitpicks
tg
More... about 2 years ago
• review use of k32/K32 ‣ the type is guaranteed to be of at least unsigned int rank so it will not default-promote to a signed type ‣ append U suffix to arith other-arguments ‣ use mbiMKror ipv old BAFHror (now gone) ‣ review uses of K32 macro (truncating cast to k32=u_int) vs. cast (to u_int) or mask • (while here) streamline BAFHFinish macro structure • introduce K32_HM and K32_FM and use in KUA_HM/KUA_FM for !lksh and stop adding casts to the mask definitions, mbi macros do that anyway • space before tab, that is crap • optimise build time: run mbi ctasserts only for some compiles • but do check it explicitly in Build.sh, abort early if failing • Build.sh: fix wording; check idstring in “final link succeeds?” as well • mbsdint.h: fix masked rotation macros: take mask bitwidth, not type’s
tg
More... about 2 years ago
if uintptr_t is present (intptr_t is useless), check it as well
tg
More... about 2 years ago
another mbsdint.h overhaul making things even less readable and more safer • more casts • write all unsigned constants with a trailing U (macros’ users, too) • more checks, even some more things that C guarantees ‣ this ensures that char has at least eight bits as a side effect though the rest of this should be fine with 7 • add 0UL to all unsigned arithmetic operands so ut==u_char no longer promotes to int (0U might have been enough plus this is inconsistent but we cannot just write 0ULL either, let’s just hope compilers DTRT) • some signed definitions for symmetry (that mostly just cast, but for arith ops also add 0, to ensure not being abused as lvalue with += etc.) • very lengthy and too verbose rewrite of the other macros using these new arithmetic ops primitives… I’m shy of making something generate these • restructuring of comments and macro ordering, hopefully makes more sense • rename existing mbiCASadd, mbiCASsub, mbiCASmul to mbiCAP* where the right-hand operand is positive or 0 • fix overflow checks in mbiCAUmul and mbiCAPmul • readd mbiCAS{add,sub,mul} with more contrived checks to allow negatives • redo rotate and shift to read more easily (and new arith ops ofc) • use new arith ops also in division/remainder
tg
More... about 2 years ago
fix shift in funsub/valsub
tg
More... about 2 years ago
fully initialise all bits in a Getopt structure
tg
More... about 2 years ago
make it possible to KSH_ULIMIT2_TEST with test-build{,-lksh}: • move TEST_BUILD_ENV closer to the beginning of the file • add to it accordingly if KSH_ULIMIT2_TEST==1 • pass LDADD as $LIBS to Build.sh • quote properly, while here
tg
More... about 2 years ago
clean up srcdir, curdir, partial objdir, handling; add altregress
tg
More... about 2 years ago
improve Makefrag compatibility with <bsd.obj.mk>
tg
More... about 2 years ago
improve Makefrag.inc generation
tg
More... about 2 years ago
note lineno issue, thanks trn via IRC
tg
More... about 2 years ago
reword this masking *again*
tg
More... about 2 years ago
• implement divrem for unsigned variable manual 2’s complement values and use that in mksh’s nōn-lksh arithmetics • implement comparison operaters (and use it), so we get that much closer to the necessary goal of signed-less (except lksh temporarily) operation • shorten the macro names and make sure all have a masking pendant and all masker do that for input as well • overhaul rotation/shift to get expressions, not statement blocks, expanded • mksh: deprecate kul (before it’s really used much) and ksl (will be used by lksh only, and only in as little arith code as possible, everything else can and will be done in unsigned, also for one’s complement and sign-and-magnitude safety), we shall only have an unsigned arithmetic type, which will be ulong at first but may later be uint if exactly 32 bits, for mksh nōn-lksh only, for simplicity (rid of masking) • recheck and improve masking • split VZU2U off VZM2U; the former takes a fullmask unsigned type on input, the latter applies halfmask to magnitude value, for consistency and reusability (mbiMA_VZM2U pretty much stays the same, mbiA_VZM2U is renamed mbiA_VZU2U and mbiA_VZM2U is added and mbiMA_VZU2U can now just mbiMM-wrap mbiA_VZU2U) • add even more intermediate value casts
tg
More... about 2 years ago
the https://www.austingroupbugs.net/view.php?id=1558 saga is still ongoing, sadly, but it’s clear this warning cannot stick for /bin/sh :~
tg
More... about 2 years ago
mbiCAUmul needs (ut) cast for intermediate values, too
tg
More... about 2 years ago
• safer ways to check lim_MIN • sign-and-magnitude and one’s-complement warning comments when appropriate ‣ add VZM2U/U2VZ/U2M which are safe if using o̲n̲l̲y̲ unsigned variables ‣ note mbiVASdivrem isn’t (we’d need mbiVAUdivrem, which can only now be constructed from VZM2U/U2VZ/U2M) • don’t inline S2VZ/U2VZ into the other macros, keeps structure better • explicitly cast SM/HM/FM into (ut) where necessary (or (st), but we only ever mask unsigned (as it should be)) • fix mbiMA_S2M to cast to unsigned before masking (ouch! we need to cast after basically all ops as integer promotions could kick in otherwise!) • note that SM (semantically, say SHRT_MAX) == HM (USHRT_MAX >> 1) (which CTAs check, btw) • cast between ops for mbiVAU{sh,ro}{l,r} (as necessary and perhaps one too much, but never not enough!)
tg
More... about 2 years ago
https://twitter.com/thingskatedid/status/1293779581074202624 is scary
tg
More... about 2 years ago
• rename bool/true/false/tobool to Wahr/Ja/Nee/isWahr¹ cf. <[email protected]> on both miros-discuss@ and miros-mksh@ for the backgrounds (tl;dr: ISO C… again) • give matching advice in style(9) • remove useless (void) casts, as style(9) says (nōn-useless ones are spelt SHIKATANAI these days anyway) • drop MKSH_A_PURE; I’m not sure I knœw where it applies, plus there’s a __const__ attribute, too, one invites that the other is also applied • correct an ord() MKC_DEBG=cpp assert
tg
More... about 2 years ago
also add ~/.local/bin (if exists) to $PATH, for pip3
tg
More... about 2 years ago
decouple tty_hasstate further from tty_fd
tg
More... about 2 years ago
Merge branch 'master' of github.com:MirBSD/mksh More... about 2 years ago
Merge branch 'master' of git+ssh://evolvis.org/scmrepos/git/alioth/mksh More... about 2 years ago
refresh More... about 2 years ago
refresh More... about 2 years ago
Merge branch 'origtgz' More... about 2 years ago
Merge branch 'origtgz' More... about 2 years ago
Update from MirBSD CVS HEAD More... about 2 years ago
Update from MirBSD CVS HEAD More... about 2 years ago
fix selftest-tty-absent
mirabilos
as tg
More... about 2 years ago